10 qt5.14 交叉编译 100ask_imx6ull 如何获得qmake?

看了教程帖子,里面使用的是qt4.8版本,

且其中获得qt sdk用于qtcreater中version的 "make 100ask_imx6ull-qt_defconfig"

内容和qt官网查到的指令不大一样 例如

-opensource \
-confirm-license \
-release \ ...

我希望使用较高版本的qt5.14

已准备部分:

1.安装了ubuntu的虚拟机

2.qt5.14的run程序 已经安装,能够正常运行自己建立的helloworld工程

3.qt5.14的源码 已解压

4.x86_64_arm-linux-gnueabihf文件并解压


请教

1.如何make出能用于100ask_imx6ull的qt sdk

2.开发板上是否需要进行什么改动 使之能供运行该5.14版本交叉编译出的程序

请先 登录 后评论

最佳答案 2021-03-18 09:55

你好 建议参考buildroot qt5包


100ask_imx6ull-sdk/Buildroot_2020.02.x$ cat package/qt5/qt5.mk


可以通过在make menuconfig选中以后 单独执行 make qt5-rebuild来查看编译所需的命令和过程进行参考


同时也可以从buildroot官方获取最新支持 qt5.14版本的源码包进行自动构建

请先 登录 后评论

其它 1 个回答

AL

..教学文档里似乎有 我去看看先

请先 登录 后评论